Sevenman's TVR (was SAAB) Blog

October 14, 2013

TVR back – faulty plug?

Filed under: TVR — Administrator @ 2:45 pm

On Friday I had a call from Jason at TVR Power to say the car was fixed.

  • He had driven it and it was ‘running like a donkey’
  • He had connected it to the computer, which said it was ‘running like a donkey’, with multiple faults.

The spark plugs were checked, and the plug for cylinder 6 was heavily fouled with fuel and not sparking at all. The HT leads and coil were checked and these were found to be fine, so they weren’t the cause.

Throttle balance for 6 was slightly out and was corrected. But not sufficiently out to have caused such an issue. And they were all balanced just 600 miles ago at the 12k service.

With a new plug the car was tested and found to be running fine. The cost for this was £0, which is nice. I picked it up early on Saturday and drove the hour home and it ran fine. It is always a bit tricky when you are listening / feeling for any hint of a problem, but I didn’t notice anything.

The bad running, noises, and excessive hear from the exhaust would have been caused by this misfire and the subsequent dumping of fuel into the exhaust. The unburnt fuel burning in the catalytic converter explains the heat and could have damaged it. I don’t recall feeling or hearing any issues at 130 mph, but the wind noise was loud and the suspension was working hard on the Millbrook surface. It was definitely off when I left the bowl after slowing down gradually and I think it then got worse over the next few miles.

Given how well the car is running now, Jason thinks that a faulty plug could be the culprit.

I still have concerns, but those can wait until spring to investigate as, from now, the car is only going out on dry days for local runs. Options to investigate include:

  • removing the cats to check operation – but the fault can’t be caused by the exhaust as it would have affected cylinders 4 and 5 as well
  • some rolling-road work to check mapping – but it is a stock map and injectors are flowing ok

It would be nice if it was as simple as a faulty plug, but I want to be really sure before I return to Millbrook and CAT Driver Training for a 3rd time…

No Comments »

No comments yet.

RSS feed for comments on this post. TrackBack URL

Leave a comment

You must be logged in to post a comment.

Powered by WordPress